Downloader
Downloader
My Local Data does not match my Online Data. Why?
The downloader no longer adjusts previously downloaded data for splits, dividends, etc. You will need to either manually adjust the data or delete it and re-download it to correct it.
In Downloader, you will want to locate the instrument you need to get adjusted data for
You can manually adjust yourself or delete the data
To adjust the data, right-click the instrument and select Adjust -> Data
Select the date you wish to adjust the data from
Enter the adjustments
Click OK
If you wish to delete the data and re-download, uncheck all other instruments.
Check the instrument, then right-click
Select Delete Data for All Checked
Click Delete
Click the Download button to re-download all historical data.
How to move securities in DownLoader?
DownLoader v17 --> Current
Open DownLoader
Open DownLoader Console
Open the folder that contains the desired security
Click the Triangle to the left of the Folder name
Right click on the Security or Securities
Select Move all checked to…
Select the desired folder in which to move to. The destination folder must already be added to the Download tab
If the desired destination folder in not in the list:
Click Cancel
Click Add
Select the desired folder
Click the Select Folder button
Click Select
How to download local data files in DownLoader?
DownLoader v15 --> Current
Make sure all of your folders are added to the list in the Download tab
The steps above should have added the folder automatically. If there are others, use the Find button to make sure they are all added
Click the Find button
Select the root folder that contains all of your data folders (e.g. Documents\MetaStock)
Click Select Folder
Check the Use current date option to ensure you have the latest complete day's data.
You can uncheck the option and set it to a date in the past if you wish. Please note that you may not current data with the option is unchecked.
Verify that the Recollect commodities option is checked if you download Futures data to ensure you are collecting the prior day's volume and open interest. If you do not collect this type of data it will not matter if this option is checked or unchecked.
Check the option to Include partial bars, if you wish to collect the current days snapshot data (does not apply to all data vendors or markets. Daily Charts does offer this service). The data will be update the next time you download data
Click the Download button in the lower, right corner of the DownLoader Console
The Download Status window will show the progress and when complete you will be prompted with the Collection Report. The report will show you all of the securities that were in the download attempt with a status indicator next to each. Green check means the download was successful. Red cross means there was an update/correction. An " X" means an Error.
Double click on the security in the report (or select the item and click Details) to see a detailed Security Report
Click Close when complete with the detailed report
Click Close to dismiss the Collection Report. If you want to see the most recent report again, open the View menu and select Last Collection Report
How to create local data files in Downloader?
Close both MetaStock and DownLoader
Go to https://www.metastock.com/customer/support/download/Symbols
Download and run the file
Open DownLoader.
From the Download tab select the Add button.
Select New Folder give the folder a name and select Select Folder.
Choose the desired data format (Legacy or MSLocal) and select OK.
The newly created folder will display in the Download tab.
Right click on the folder, select Create New Security.
There are three ways in which to add an instrument to the folder, those are covered below.
1. Click Lookup and type a symbol. Select from the list the symbol you wish and click OK
2. Type a symbol. If you do all lower case it will automatically convert the symbol to caps. If you mix the symbols (e.g., Ibm or IBm) the system assumes you want the mixed case and will not correct.
3. Check Multiple Instrument Lookup, Click lookup. This allows you to select multiple instruments by checking the ones you want or checking an existing list and adding all to the folder.
Click OK.
Select the Interval.
Select the First Date (This will be the first date in the data file. If you want five years of data set the first date back five years).
Once an instrument is entered select OK to add the symbol and close the dialog or Create to add the symbol and leave the dialog open to add additional instruments to the folder.
This will add the instrument(s) to the folder.
To download data to the new folder, place a check next to the folder and select the Download button.
Once the download is completed, you will need to add the data into MetaStock.
In the Power Console double click on Local Data Lists or right click on Local Data Lists and select New.
Enter a name for the list.
Click Browse.
Click Browse again if your files are located in a different folder than what is displayed.
Open the folder that contains your local data and click the Select Folder button.
Select the instrument(s) and click Add.
Click Save when completed.
How do I delete local securities in DownLoader?
Downloader v15 --> Current
Open DownLoader.
From the Download tab in the console, expand the folder that contains the data file by selecting the triangle.
Place a check next to the data file to be deleted.
Right-click on the data file in which you wish to remove.
Select Delete.
If you wish to delete multiple data files from a folder, check the desired data files.
Right-click on the folder path and select Delete all checked...
How to copy securities in DownLoader?
DownLoader v15 --> Current
Open DownLoader
Open DownLoader Console
Open the folder that contains the desired security
Click the Triangle to the left of the Folder name
Right click on the Security or Securities
Select Copy all checked to…
Select the desired folder in which to copy to. The destination folder must already be added to the Download tab
If the desired destination folder in not in the list:
Click Cancel
Click Add
Select the desired folder
Click the Select Folder button
Click Select
How to convert Legacy data to CSV in DownLoader?
DownLoader 15 - Current
The DownLoader can be used to convert Legacy Local Data files to CSV files. This document will help you convert your legacy MetaStock files to CSV file format.
Select the Convert tab in the DownLoader Console.
In the Source section, set the File type to Legacy.
Click the Browse button to select the parent folder that contains your old Legacy files (e.g. C:\MetaStock Data). If there are multiple sub-folders, these will be added automatically. You can deselect a folder or a security by unchecking it on the left side.
In the Destination section, set the File type to CSV
Select a Destination folder in which to create your new CSV files. If you wish to create a new sub-folder to help organize your data, click the New folder button.
Check the option to Overwrite matching data records in destination if you wish to replace the old data in the destination file with potentially newer data from the source. Leave this unchecked if you wish to preserve the data already in the destination file.
Click the Convert button.
How to convert CSV to MSLocal format in DownLoader?
Downloader 15 - Current
The new file format database will support up to 100000 individual securities and can contain 100000 records each in one repository (folder). Each repository will have its own database. The file can grow quite large.
DownLoader 15
To convert a Legacy MetaStock file to the new MetaStock local data file in DownLoader XV:
Open DownLoader Console with the D button or File > Open DownLoader Console.
Select the Convert tab in the DownLoader Console.
In the Source section, set the File type to CSV.
Click the Browse button on the upper right to select the parent folder that contains your CSV files (e.g. Documents).
In the Destination section, set the File type to MSLocal
Select a Destination folder in which to create your new local data files by clicking the Browse button on the lower right. If you wish to create a new sub-folder to help organize your data, click the New folder button.
Check the option to Overwrite matching data records in destination if you wish to replace the old data in the destination file with potentially newer data from the source. Leave this unchecked if you wish to preserve the data already in the destination file.
Click the Convert button.
How to Adjust First Date of securities in DownLoader?
Downloader 15 - Current
If you would like to add more data to your existing local data files, you can adjust the first date and re-download the data to fill in the extra historical data.
Open DownLoader.
Open DownLoader Console.
Select the Download tab.
To change a single symbols first date right click on the security in which you wish to adjust then select Adjust first date
To adjust the first date on several symbols, select the desired securities by checking the boxes to the left of each one then right click on the folder containing the securities to select Adjust first date for all checked.
Set the desired date. The Date must be prior to the existing First date. Setting it to a later date could lead to deleting data. A warning message will appear if data would be deleted.
Click OK.
The next time data is downloaded, the extra data will be appended to the file(s).
How do I view the most recent conversion report in DownLoader?
Downloader v15 - Current
Open DownLoader.
Select View from the main menu.
Select Last Conversion Report.
To view additional details select an item in the collection report and select Details (or double click on the items).
You can change the Status to view the items that were in the OK or Error status (or both).
Select Close to close the conversion report.
How do I view the most recent collection report in DownLoader?
Downloader v15 - Current
Open DownLoader.
Select View from the main menu.
Select Last Collection Report.
To view additional details select an item in the collection report and select Details (or double click on the items).
You can change the Status to view the items that were in the OK or Error status (or both).
Select Close to close the collection report.
How do I start DownLoader?
Downloader v15 --> Current
There are several ways to start the DownLoader application.
To start DownLoader from the Windows Start menu:
Click on the Windows Start menu
Select All Apps (or All Programs depending on the version of Windows that you are running)
Open the Refinitiv folder
Select DownLoader
To start DownLoader from within MetaStock:
From the Tools menu:
Open the Tools menu
Select DownLoader (sixth down the list)
From the Standard Toolbar:
Click your mouse on the DownLoader icon in the toolbar at the top of the application
How do I open a datasheet of my data in DownLoader?
Downloader v15 - Current
Open DownLoader.
From the console select the Download tab.
Expand the folder that contains the data file.
To open a single datasheet, place a check next to the data file, right click onto it and select View Security Data.
To open multiple datasheets (the maximum amount of datasheets that can be open at once is 20).
Check the desired data files, right click onto one of the selected items.
Select View Security data for all checked...
How do I download data in DownLoader?
Downloader v15 --> Current
Add all your folders to the Download tab in the console.
If you are downloading multiple sub-folders under a parent folder, e.g. after installing the MetaStock Utility: click the Find button.
Select the parent folder that contains all of your data folders.
If you are downloading a single folder, use the Add button.
Select the parent folder that contains your data folder (e.g. Documents\MetaStock)
Click Select Folder.
Check the Use Current Date option to ensure you have the latest complete day's data.
You can uncheck the option and set it to a date in the past if you wish (NOTE* that you may not get current data with the option unchecked).
Verify that the Recollect commodities options is checked if you download Futures data to ensure you are collecting the prior day's volume and open interest (NOTE* If you do not collect Futures data it will not matter if this option is checked or unchecked).
Select the Download button to begin the data collection.
When the download is complete the Collection Report will appear.
A green check means the download was successful.
Read cross means there was an update\correction.
An "X" means an error occurred. (invalid symbol, connection issue)
How do I copy securities in DownLoader
Downloader v15 --> Current
Open DownLoader.
From the console, expand the folder that contains the data files to be copied by selecting the triangle to the left.
Place a check next to the data files to be copied.
Then right-click on the checked data files and from the menu select, Copy all checked to.../li>
From the Copies Securities dialog select the folder in which to copy to.
The destination folder must already be added to the DownLoad tab.
If the desired destination folder is not in the list:
Select Cancel
Select Add
Select the desired folder, then choose the Select Folder button.
Select the desired data type (MSLocal or Legacy) and select the OK button.
How do I convert MSLocal data to CSV in DownLoader?
Downloader v15 --> Current
With the release of DownLoader 15 we also released our new file format. This document will help you convert your MSLocal files to the CSV format.
Open DownLoader
Select the Convert tab in the Console.
In the Source section, set the File type to MSLocal.
Click the Browse button to select the folder that contains MSLocal data files.
Multiple sub-folders will be added automatically.
Folder(s)\instrument(s) can be deselected from the left side.
Sub-folders can be added individually.
If another security or folder is added later under the same parent folder, you can click the Refresh button to reload.
In the Destination section, set the File type to CSV.
Select a Destination folder in which to create the new CSV files.
Check the option to Overwrite matching data records in the destination, if you wish to replace the data in the destination file with the data from the source file.
Leave this unchecked if you wish to preserve the data in the destination file.
Select the Convert Folder button.
How do I convert Legacy data to MSLocal data format in Downloader?
Downloader v15 --> current version
The MetaStock file format database will support up to 100000 individual securities and can contain 100000 records each. Each folder will have it's own database.
Open DownLoader.
Select the Convert tab from the console.
In the source section, set the File type to Legacy.
Click the browse button to select the parent folder that contains the legacy files. (e.g. c:\MetaStock Data)
If there are multiple sub-folders, these will be automatically added. Folders can be deselected by unchecking it from the left side.
You can also add the sub-folder individually.
If another security or folder is added later under the same parent folder, you can click the Refresh button to reload the list of securities/folders.
In the Destination section, set the File type to MSLocal.
Select a destination folder in which to create your new local data files (e.g. Under your Documents folder, select the MetaStock folder).
If you wish to create a new sub-folder to help organize your data, click the New Folder button.
Name it accordingly.
Check the option to Overwrite matching data records in destination if you wish to replace the old data in the destination file with potentially newer data from the source. Leave this unchecked if you wish to preserve the data already in the destination file.
Click the Convert button.
If the Convert button is grayed out, more than likely a destination folder has not been selected.
How do I adjust data in DownLoader?
If you need to quickly adjust local data, follow the steps below:
DownLoader v17 --> Current
To adjust a single instrument:
Open DownLoader.
Open the DownLoader Console.
Add the folder that contains the data that you wish to adjust.
Expand the folder and right click on the desired instrument.
Select Adjust.
Select Data.
Select the fields that you wish to adjust (Open, High, Low, Close, Volume, and/or Open Interest)
Enter the Factor that you wish to adjust by.
Select the date range of data to be adjusted from the Dates to Adjust
Click OK.
To adjust a multiple instruments:
Open DownLoader.
Open the DownLoader Console.
Add the folder that contains the data that you wish to adjust.
Expand the folder
Select the desired instruments.
Right click on the Folder name
Select Adjust for all checked.
Select Data.
Select the fields that you wish to adjust (Open, High, Low, Close, Volume, and/or Open Interest)
Enter the Factor that you wish to adjust by.
Select the date range of data to be adjusted from the Dates to Adjust
Click OK.
Why can't Downloader & MetaStock read my Legacy Data files?
It sounds like some files in the folder may have become damaged or
corrupted. Below, I’ve outlined a few straightforward steps you can try
to manually repair the directory.
How to Repair Your Data Folder:
(1) Close all related software
Make sure MetaStock, The Downloader, and any other programs that access your data are fully closed.
(2) Check the folder contents
Open your local data folder in File Explorer.
A healthy folder should only contain:
EMASTER (1 file)
MASTER (1 file)
XMASTER (only needed if the folder holds more than 255 securities)
F#.DAT files (for example, F1.DAT, F2.DAT, and so on)
F#.DOP files
(3) Remove or rename temporary or problem files
Look for any files ending in .TMP or containing ~MSFL. These are common causes of read errors.
Delete all files that contain ~MSFL in the name.
Delete .TMP files (for example, EMASTER.TMP) only if the standard version (for example, EMASTER) already exists in the folder.
If the standard version is missing, try renaming the .TMP file to its normal name (for example, rename EMASTER.TMP to EMASTER).
After making these changes, restart MetaStock and see if the folder loads correctly.
Stock splits - how to delete unadjusted data and download adjusted data
When a stock split occurs, when you download data, going forward, the newly downloaded data will already be adjusted, but it doesn't go backward and adjust the prior to your already existing prior downloaded data. To do that, you'll need to delete the data and download it fresh, so that it will all come in adjusted.
The steps to delete and download the data fresh are here:
1. Open Downloader.
2. Place a check mark next to only the stock or stocks that you want to do this for.
3. Right-click on any of them, then click "Delete data for all checked...".
4. Set the Date to 1 day in the future (tomorrow's date) and select "Delete Before".
5. Click Delete.
6. Now click Download to download the fresh adjusted data.
Can I convert intraday data in CSV format to MetaStock format?
Intraday CSV data cannot be converted to the MetaStock format. If you have MetaStock RT, the program can read the CSV file directly.